Login  |  Packages  |  Support  |  Bugs
Top Level :: Event :: swoole :: 4.4.15

swoole 4.4.15

Package Information
Summary Event-driven asynchronous and concurrent networking engine with high performance for PHP.
Maintainers shen zhe < shenzhe163 at gmail dot com > (developer) [details]
Han Tianfeng < mikan dot tenny at gmail dot com > (lead) [details]
QiHao ChenCao < twose at qq dot com > (developer) [details]
License Apache2.0
Description Event-driven asynchronous and concurrent networking engine with high performance for PHP.
- event-driven
- coroutine
- asynchronous non-blocking
- multi-thread reactor
- multi-process worker
- multi-protocol
- millisecond timer
- built-in tcp/http/websocket/http2 server
- coroutine tcp/http/websocket client
- coroutine mysql client
- coroutine redis client
- coroutine read/write file system
- coroutine dns lookup
- support IPv4/IPv6/UnixSocket/TCP/UDP
- support SSL/TLS encrypted transmission
Homepage https://github.com/swoole/swoole-src
Release notes
Version 4.4.15
(stable)
Enhancement
---
+ Bad websocket handshake request will respond 400 (fdc1cb67) (@twose)
+ Disable accept when have too many connections (dd9fbf2f) (@matyhtf)
+ Binary security of package_eof (#3054) (@twose)
+ Support HTTP chunked request (#3055) (@twose)
+ Unified naming style and improve accessibility of Curl\Handler properties (library/curl) (@twose)

Fixed
---
* Fixed Http\Response->close (d30e3269) (@twose)
* Fixed possible memory overflow (2212e091) (@twose)
* Fixed memory error when MSHUTDOWN (undestroyed reactor) (78d6dd73) (@twose)
* Fixed handler of event HUP (#3046) (@matyhtf) (@twose)
* Fixed exit code 1 (f982b817) (@matyhtf) (@twose) (@qiqizjl)
* Fixed missing "unhook curl_multi_getcontent" (7b2e960e) (@twose)
* Fixed Coroutine HTTP2 Server memory error (d90eebe6) (@twose)
* Fixed http_context_send_data (#3059) (@twose)
* Fixed send_yield in BASE mode (edbb654d) (1b8096e9) (@twose)
* Refactor HTTP2 Server to fix some bugs (#3061) (@twose)
* Fixed behaviour of CURLOPT_POSTFIELDS, CURLOPT_HTTPHEADER, curl_close (library/curl) (@twose)

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source ] [ Package Bugs ] [ View Documentation ]

Dependencies for release 4.4.15
PHP Version: PHP 7.1.0 or newer
PEAR Package: PEAR 1.4.0 or newer
PHP Version: PHP 7.1.0 or newer
PEAR Package: PEAR 1.4.0 or newer
PRIVACY POLICY  |  CREDITS
Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 27 13:05:01 2019 UTC
Bandwidth and hardware provided by: pair Networks