Login | Packages | Support | Bugs 

Top Level :: Images :: imagick

imagick 3.4.0RC1

Package Information
Summary Provides a wrapper to the ImageMagick library.
Maintainers Mikko Koppanen <mkoppanen@php.net> (lead) [wishlist] [details]
Scott MacVicar <scottmac@php.net> (lead) [details]
Dan Ackroyd (lead) [wishlist] [details]
License PHP License
Description Imagick is a native php extension to create and modify images using the ImageMagick API.
This extension requires ImageMagick version 6.5.3-10+ and PHP 5.4.0+.
Release notes
Version 3.4.0RC1
(beta)
- Added support:
* PHP 7
* ImageMagick 7. Imagick can be compiled against either ImageMagick 6 or ImageMagick 7
However it must be run with the exact same version it was compiled against. Trying
to run Imagick with a different version of ImageMagick than it was compiled against
is not supported. Please see http://nextgen.imagemagick.org/script/porting.php for
more information about ImageMagick 7.
- Minimum versions supported are now PHP >= 5.4.0 and ImageMagick >= 6.5.3-10.
Earlier versions may continue to work, but they are no longer supported.
- Added methods:
* Imagick::getConfigureOptions
* Imagick::getFeatures
* Imagick::getHDRIEnabled
* Imagick::setImageChannelMask (IM7 only)
- Added IM7 constants:
* Imagick::CHANNEL_READ_MASK
* Imagick::CHANNEL_WRITE_MASK
* Imagick::CHANNEL_META
- Fixes:
* ImagickPixel::getColorQuantum, ImagickPixel::getColorValueQuantum and
ImagickPixel::setColorValueQuantum now correctly use floats when Imagick
was compiled against a HDRI version of ImageMagick
* Imagick::exportImagePixels works for all storage types

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ][ View Documentation ]
[ Report new bug ]

Dependencies for release 3.4.0RC1
PRIVACY POLICY | CREDITS
Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Thu Mar 26 06:22:20 2015 UTC
Bandwidth and hardware provided by: pair Networks