Login | Packages | Support | Bugs 

Top Level :: Internationalization :: intl

intl 3.0.0b1

Package Information
Summary Internationalization extension
Maintainers Stanislav Malyshev <stas@php.net> (lead) [details]
Kirti Velankar (developer) [details]
Gustavo Lopes <cataphract@php.net> (lead) [details]
License PHP License
Description The Internationalization extension exposes functionality of the ICU library to PHP.

This extension has been bundled with PHP since version 5.3. This PECL version backports improvements made in the development version of PHP to PHP 5.2-5.4.
Version 3.0 is in sync with PHP 5.5; binaries are nonetheless provided here. They may be preferrable to those bundled with PHP 5.5 due to being compiled against a more recent version of ICU.

Windows binaries (VC 9, x86, 3.0.0):
The binaries depend on the ICU libraries (version 51.2 for 3.0.0), which must be available to PHP.

This extension is compatible with PHP 5.2; however, no Windows binaries will be provided for that PHP version.
Homepage http://www.icu-project.org/
Release notes
Version 3.0.0b1
(beta)
- Add UConverter class (ICU's UConverter API).
See RFC at http://wiki.php.net/rfc/uconverter
- Fixed defective cloning of subclassed intl classes. See also bug #62915.
- Allow Spoofchecker to be registered on ICU versions with .1 minor numbers like
ICU 49.1.
- Fix SPOOFCHECKER_METHOD_FETCH_OBJECT definition.
- Fix handling of several uinitialized intl objects.
- Added the intl tests extracted from Symfony.
- Fixed several tests.

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ][ View Documentation ]
[ Report new bug ]

Dependencies for release 3.0.0b1
PHP Version: PHP 5.2.4 or newer
PEAR Package: PEAR 1.4.8 or newer
PRIVACY POLICY | CREDITS
Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Tue Oct 15 08:05:03 2013 UTC
Bandwidth and hardware provided by: pair Networks