Login | Packages | Support | Bugs 

Top Level :: Images :: GDChart

GDChart 0.2.0

Package Information
Summary GDChart Based Graphing Interface
Maintainers Ilia Alshanetsky <ilia@php.net> (lead) [details]
Rasmus Lerdorf <rasmus@php.net> (lead) [details]
License PHP
Description The GDChart extension provides an interface to the bundled
gdchart library. This library uses GD (bundled) library to generate
20 different types of graphs based on supplied parameters.

The extension provides an OO interface to gdchart exposing
majority of options via properties and complex (array) options via
a series of methods.

To use the current version of the extension PHP 5.0.0 is required,
and older PHP 4 only version can be downloaded from CVS, by checking
out the extension with PECL_4_3 tag.
Release notes
Version 0.2.0
(beta)
Rewrite of the extension to allow it to work with PHP 5.1
Changes include the following:
* virtual properties implemented via getter/setter are now real
* all array options can only be set via supplied methods
* properties & methods follow studlyCaps naming conventions
* all constants are now class constants
* fixed a number of potential crashes due to missing input validation
* fixed memory leaks in gdchart library

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ]
[ Report new bug ]

Dependencies for release 0.2.0
PHP Version: PHP version 6.0.0 or older
PHP Version: PHP 5.0.0 or newer
PEAR Package: PEAR 1.4.1 or newer
PHP Extension: gd
PRIVACY POLICY | CREDITS
Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Tue Oct 15 08:05:03 2013 UTC
Bandwidth and hardware provided by: pair Networks