Login | Packages | Support | Bugs 

Top Level :: File Formats :: yaml :: Windows

yaml 2.0.0

Package Information
Summary YAML-1.1 parser and emitter
Maintainers Bryan Davis <bd808@php.net> (lead) [details]
License MIT
Description Support for YAML 1.1 (YAML Ain't Markup Language) serialization using the
LibYAML library.
Homepage http://bd808.com/pecl-file_formats-yaml/
Release notes
Version 2.0.0
(stable)
Breaking changes:
- #69617 yaml.decode_php ini setting now defaults to false.
New Features:
- PHP7 compatible
- 2.x series will no longer support PHP5
Bugs Fixed:
- Premature free in y_write_object (remicollet)
- Uninitialized smart_str in convert_to_char (remicollet)
- Missing free in convert_to_char (remicollet)
- Use zend_* datatypes (weltling)
- Fix handling of optional encoding argument to yaml_emit_file (weltling)
- Removed PHP6 compat IS_UNICODE support (bd808)
- Fixed parameter parsing for yaml_emit_file()
- Fixed callback usage for yaml_emit_file()
- Use smart_str_free() instead of smart_string_free() (remicollet)
- #71045 zend_mm_alloc_small crashes with zend_string_alloc
- Fix handling of tag callbacks for aliased values (ranvis)
- Quick fix on handle_mapping. arrval should be used instead of retval (jabiinfante)
- #71696 Bad datetime management (bocharov)
- Fix memory leak in mapping with sequence (bocharov)
- Fix anchor in anchor problemo (bocharov)
- Fix tests bug_64019.phpt, bug_parsing_alias.phpt (bocharov)
- #72204 Crash when try to parse yaml file
 
DLL List
PHP 7.0 7.0 Non Thread Safe (NTS) x86
7.0 Thread Safe (TS) x86
7.0 Non Thread Safe (NTS) x64
7.0 Thread Safe (TS) x64

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ][ View Documentation ]

Dependencies for release 2.0.0
PHP Version: PHP 7.0.0-dev or newer
PEAR Package: PEAR 1.4.0b1 or newer
PHP Extension: date
PRIVACY POLICY | CREDITS
Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Fri Mar 27 06:05:02 2015 UTC
Bandwidth and hardware provided by: pair Networks