Login | Packages | Support | Bugs 

Top Level :: Images :: qb :: Windows

qb 2.4.0

Package Information
Summary Accelerator designed mainly for graphic work
Maintainers Chung Leong <cleong728@gmail.com> (lead) [details]
License PHP License
Description QB stands for "Quick Binary." It's a PHP extension designed to enable faster handling of binary data. It takes a function written in PHP and translate it for a specialized virtual machine. The use of static type information leads significantly higher performance than under PHP's regular dynamic type system. A PHP+QB function can run anywhere from five to twenty times faster than regular PHP code. For even higher level of performance, one can compile PHP+QB functions to native code (on supported platforms).

QB performs code translation on a per-function basis. It does not affect in anyway code not specially marked. Interaction between PHP+QB functions and regular PHP code is basically seamless. A key design objective of QB is to let developers harness greater processing power than what baseline PHP offers without the risk involved in adopting a brand new platform.
Homepage http://www.php-qb.net
Release notes
Version 2.4.0
(stable)
Added option to emit errors as exceptions
Fixed issue #36 - Incorrect cast to int
Fixed issue #39 - Incompatibility with namespace usage
Fixed issue #40 - Incompatibility with namespace usage
Fixed issue #42 - Inability to append to array
Fixed issue #43 - Segfault when opcache is used
Fixed issue #46 - Incorrect array size when initialized with empty array
Fixed issue #48 - Memory-mapped file don't get released on function exit
Fixed issue #49 - Multiple static arrays cause failure to compile to native code
Fixed issue #50 - Cannot pass GD image as int8[][4]
Fixed issue $51 - Multithreading fails when pcntl_fork() is used
 
DLL List
PHP 5.6 5.6 Non Thread Safe (NTS) x86
5.6 Thread Safe (TS) x86
5.6 Non Thread Safe (NTS) x64
5.6 Thread Safe (TS) x64
PHP 5.5 5.5 Non Thread Safe (NTS) x86
5.5 Thread Safe (TS) x86
5.5 Non Thread Safe (NTS) x64
5.5 Thread Safe (TS) x64
PHP 5.4 5.4 Non Thread Safe (NTS) x86
5.4 Thread Safe (TS) x86

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ]
[ Report new bug ]

Dependencies for release 2.4.0
PHP Version: PHP 5.2.0 or newer
PEAR Package: PEAR 1.4.8 or newer
PRIVACY POLICY | CREDITS
Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Tue Oct 15 08:05:03 2013 UTC
Bandwidth and hardware provided by: pair Networks