Login | Packages | Support | Bugs 

Top Level :: Database :: mongodb :: Windows

mongodb 1.5.2

Package Information
Summary MongoDB driver for PHP
Maintainers Derick Rethans <derick@php.net> (lead) [wishlist] [details]
Jeremy Mikola <jmikola@gmail.com> (lead) [details]
Hannes Magnusson <bjori@php.net> (lead) [details]
Katherine Walker (developer) [details]
License Apache License
Description The purpose of this driver is to provide exceptionally thin glue between MongoDB
and PHP, implementing only fundamental and performance-critical components
necessary to build a fully-functional MongoDB driver.
Homepage http://docs.mongodb.org/ecosystem/drivers/php/
Release notes
Version 1.5.2
(stable)
** Bug
* [PHPC-1110] - advanceOperationTime test failure
* [PHPC-1239] - Passing empty driversOptions array to Manager constructor overrides SSL options in URI
* [PHPC-1241] - OpenSSL 1.1 not found if pkg-config is not available
* [PHPC-1243] - Calling session methods after Session::endSession() causes use-after-free crash

** Task
* [PHPC-1184] - Add alternative topologies to Travis CI
* [PHPC-1205] - Allow unencoded subdelimiters in usernames and passwords
* [PHPC-1227] - Document that transactions do not allow per-op read/write concerns
* [PHPC-1244] - Use majority WC to drop/create collections for transaction tests
* [PHPC-1246] - Document class tree for exception classes
* [PHPC-1248] - Add test to ensure that URI constant is successfully parsed
* [PHPC-1249] - Fix tests running against MongoDB 3.0 replicaset
* [PHPC-1251] - Upgrade libmongoc to 1.12.0
 
DLL List
PHP 7.2 7.2 Non Thread Safe (NTS) x64
7.2 Thread Safe (TS) x64
7.2 Non Thread Safe (NTS) x86
7.2 Thread Safe (TS) x86
PHP 7.1 7.1 Non Thread Safe (NTS) x64
7.1 Thread Safe (TS) x64
7.1 Non Thread Safe (NTS) x86
7.1 Thread Safe (TS) x86
PHP 7.0 7.0 Non Thread Safe (NTS) x64
7.0 Thread Safe (TS) x64
7.0 Non Thread Safe (NTS) x86
7.0 Thread Safe (TS) x86
PHP 5.6 5.6 Non Thread Safe (NTS) x64
5.6 Thread Safe (TS) x64
5.6 Non Thread Safe (NTS) x86
5.6 Thread Safe (TS) x86

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ][ View Documentation ]

Dependencies for release 1.5.2
PHP Version: PHP version 7.99.99 or older
PHP Version: PHP 5.5.0 or newer
PEAR Package: PEAR 1.4.8 or newer
PRIVACY POLICY | CREDITS
Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Aug 08 15:05:02 2018 UTC
Bandwidth and hardware provided by: pair Networks