Login  |  Packages  |  Support  |  Bugs
Top Level :: Languages :: v8 :: 0.2.2

v8 0.2.2

Package Information
Summary V8 JavaScript engine API for PHP
Maintainers Bogdan Padalko (lead) [details]
Stefan Siegl < stesie at brokenpipe dot de > (lead) [details]
License The MIT License (MIT)
Description This extension brings V8 JavaScript engine API to PHP with some abstraction in mind and provides an accurate native V8 C++ API implementation available from PHP.
Homepage https://github.com/pinepain/php-v8
Release notes
Version 0.2.2
(stable)
I'm excited to announce that starting from this release documentation is available at
https://php-v8.readthedocs.io.

Read The Docs is awesome place to host documentation and Sphinx would help to create decent documentation.
Contributors welcomed!

This is the last version that supports PHP 7.1. Nex versions wil reqiure PHP >= 7.2 unless further notice.

BC-breaking changes:

- Upgrade v8 version to 6.6.313
- Remove deprecated and non-working ScriptCompiler cache options
- Rework PromiseObject
- Add ValueObject::isBigInt64Array() and ValueObject::isBigUint64Array methods

Non-breaking changes:

- Add number of native and detached contexts to HeapStatistics
- Add support to produce code cache
- Add ScriptCompiler::OPTION_EAGER_COMPILE option
- Add support for integer-<strings for ObjectValue::GetOwnPropertyNames and `ObjectValue::GetPropertyNames
- Add {Template,ObjectValue}:setLazyDataProperty() method

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source ] [ Package Bugs ]
[ Report new bug ]

Dependencies for release 0.2.2
PHP Version: PHP 7.1 or newer
PEAR Package: PEAR 1.4.0 or newer
PRIVACY POLICY  |  CREDITS
Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jan 27 13:05:01 2019 UTC
Bandwidth and hardware provided by: pair Networks