Login | Packages | Support | Bugs 

Top Level :: Images :: imagick

imagick 0.9

Package Information
Summary Provides a wrapper to the ImageMagick library.
Maintainers Mikko Koppanen <mkoppanen@php.net> (lead) [wishlist] [details]
Scott MacVicar <scottmac@php.net> (lead) [details]
License PHP License
Description Imagick is a native php extension to create and modify images using the ImageMagick API.
This extension requires ImageMagick version 6.2.4+ and PHP 5.1.3+.

IMPORTANT: Version 2.x API is not compatible with earlier versions.
Release notes
Version 0.9
(beta)
IMPORTANT!!!
This release breaks BC with the 0.1.x series of ext/imagick.
read the examples for more information (in $doc_dir/imagick/examples)

0.2-0.5 were never released within PEAR.

- functions added:
imagick_next()
imagick_prev()
imagick_first()
imagick_goto()
imagick_getlistsize()
imagick_getlistindex()
imagick_getimagefromlist()
imagick_blob2image()
imagick_reducenoise()
imagick_shade()
imagick_sharpen()
imagick_spread()
imagick_threshold()
imagick_unsharpmask()
- cut over deprecation reporting to a more standized and easier
to use method
- cut over all php_error calls to standard method
- added Christian's code to info function for displaying a list of
supported image formats
- rewrote all code to use proper parameter parsing function
- fixed minor issue with a number of example files; was nothing
critical

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ][ View Documentation ]
[ Report new bug ]

Dependencies for release 0.9
PRIVACY POLICY | CREDITS
Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Tue Oct 15 08:05:03 2013 UTC
Bandwidth and hardware provided by: pair Networks