Login | Packages | Support | Bugs 

Top Level :: Images :: imagick

imagick 3.2.0b2

Package Information
Summary Provides a wrapper to the ImageMagick library.
Maintainers Mikko Koppanen <mkoppanen@php.net> (lead) [wishlist] [details]
Scott MacVicar <scottmac@php.net> (lead) [details]
License PHP License
Description Imagick is a native php extension to create and modify images using the ImageMagick API.
This extension requires ImageMagick version 6.2.4+ and PHP 5.1.3+.

IMPORTANT: Version 2.x API is not compatible with earlier versions.
Release notes
Version 3.2.0b2
(beta)
- A lot of internal improvements on the code
- Added ImagickPixel::isPixelSimilar and deprecate ImagickPixel::isSimilar #10
- Added imagick::smushimages
- Added imagick::blueshiftimage and imagick::clampimage
- Added Imagick::autolevelimage
- Added constants:
Imagick::ALPHACHANNEL_REMOVE
Imagick::ALPHACHANNEL_FLATTEN
Imagick::RESOURCETYPE_THREAD
Imagick::COMPOSITE_CHANGEMASK
Imagick::COMPOSITE_LINEARLIGHT
Imagick::COMPOSITE_DIVIDE
Imagick::COMPOSITE_DISTORT
Imagick::COMPOSITE_BLUR
Imagick::COMPOSITE_PEGTOPLIGHT
Imagick::COMPOSITE_VIVIDLIGHT
Imagick::COMPOSITE_PINLIGHT
Imagick::COMPOSITE_LINEARDODGE
Imagick::COMPOSITE_LINEARBURN
Imagick::COMPOSITE_MATHEMATICS
Imagick::COMPOSITE_MODULUSADD
Imagick::COMPOSITE_MODULUSSUBTRACT
Imagick::COMPOSITE_MINUSDST
Imagick::COMPOSITE_DIVIDEDST
Imagick::COMPOSITE_DIVIDESRC
Imagick::COMPOSITE_MINUSSRC
Imagick::COMPOSITE_DARKENINTENSITY
Imagick::COMPOSITE_LIGHTENINTENSITY
Imagick::FILTER_KAISER
Imagick::FILTER_WELSH
Imagick::FILTER_PARZEN
Imagick::FILTER_LAGRANGE
Imagick::FILTER_SENTINEL
Imagick::FILTER_BOHMAN
Imagick::FILTER_BARTLETT
Imagick::FILTER_JINC
Imagick::FILTER_SINCFAST
Imagick::FILTER_ROBIDOUX
Imagick::FILTER_LANCZOSSHARP
Imagick::FILTER_LANCZOS2
Imagick::FILTER_LANCZOS2SHARP
Imagick::FILTER_ROBIDOUXSHARP
Imagick::FILTER_COSINE
Imagick::FILTER_SPLINE
Imagick::FILTER_LANCZOSRADIUS
Imagick::COMPRESSION_ZIPS
Imagick::COMPRESSION_PIZ
Imagick::COMPRESSION_PXR24
Imagick::COMPRESSION_B44
Imagick::COMPRESSION_B44A
Imagick::COMPRESSION_LZMA
Imagick::COMPRESSION_JBIG1
Imagick::COMPRESSION_JBIG2

[ Latest Tarball ] [ Changelog ] [ View Statistics ]
[ Browse Source[ Package Bugs ][ View Documentation ]
[ Report new bug ]

Dependencies for release 3.2.0b2
PHP Version: PHP 5.1.3 or newer
PEAR Package: PEAR 1.4.0 or newer
PRIVACY POLICY | CREDITS
Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Tue Oct 15 08:05:03 2013 UTC
Bandwidth and hardware provided by: pair Networks